Updates in testing

Benutzeravatar
d.oertel
Beiträge: 3111
Registriert: 04 Jun 2008, 14:27

Updates in testing

Beitragvon d.oertel » 08 Sep 2017, 13:30

Dear opsi users

Hereby we release updates to testing release of the last week.
https://forum.opsi.org/viewtopic.php?f=10&t=9465
(Thank you for the feedback).
Also we release some additional packages.

* opsi-client-agent 4.0.7.22-1
Important changes:
* opsiclientkiosk
* fixed: wrong names of the translation files (.po)
* fixed: Problems adapting the opsi-client-kiosk to your Corporate Identity (CI)


Also as testing published:
* swaudit (4.0.7.6-2)
Important changes:
This product is now platform independent and works with Windows and with Linux.
So the Linux product l-swaudit is now obsolete and will not be maintained any more.

* opsi-linux-client-agent (4.0.7.13-1)
This version contains the new opsi-script 4.12.0.4

* New Dokumentations:
http://download.uib.de/opsi4.0/testing/opsi-v407/doc/opsi-winst-manual-en.pdf
http://download.uib.de/opsi4.0/testing/opsi-v407/doc/html/en/opsi-manual/opsi-manual.html

As testing we publish:

Localboot products

* opsi-client-agent 4.0.7.22-1
* opsi-winst 4.12.0.4-1
* swaudit (4.0.7.6-2)

opsi-linux products

* opsi-linux-client-agent (4.0.7.13-1)
* swaudit (4.0.7.6-2)



Happy testing

detlef oertel


Changelogs:
-----------
opsi-client-agent (4.0.7.22-1) stable; urgency=low

* update to opsiclientkiosk 4.0.7.10
fixes for reading opsiclientkiosk.ini
All Section titles start with capital letter

-- Detlef Oertel <d.oertel@uib.de> Wed, 06 Sep 2017:15:00:00 +0200

opsi-client-agent (4.0.7.21-1) stable; urgency=low

* fix wrong file names in opsiclientkiosk/locale file

-- Detlef Oertel <d.oertel@uib.de> Thu, 04 Sep 2017:15:00:00 +0200

opsi-client-agent (4.0.7.20-1) stable; urgency=low

* upgrade to opsi-notifier 4.0.7.2
* new opsiclientd.conf (default shutdown_warning_times increased to 3600sec;
and shutdown_warning_time added to software_on_demand-event) [eu]
* upgrade to opsi-script 4.11.6.15
* remove cmd64.exe creation from service_setup.cmd and 50_opsi-client-agent.cmd

-- Detlef Oertel <d.oertel@uib.de> Thu, 24 Aug 2017:15:00:00 +0200


opsi-client-agent (4.0.7.19-1) stable; urgency=low

* upgrade opsiclientd 4.0.92
* opsi-kiosk-client 4.0.7.9
* opsi-notifier 4.0.7.1
* opsi-systray program 4.0.7.1

-- Erol Ueluekmen <e.ueluekmen@uib.de> Mon, 21 Aug 2017:16:33:00 +0200


opsi-client-agent (4.0.7.18-1) stable; urgency=low

* upgrade opsiclientd 4.0.91

-- Erol Ueluekmen <e.ueluekmen@uib.de> Tue, 09 Aug 2017:00:33:00 +0200


opsi-client-agent (4.0.7.17-1) stable; urgency=low

* upgrade notifier 4.0.7.1
* new opsi-systray program 4.0.7.1

-- Detlef Oertel <d.oertel@uib.de> Tue, 18 Jul 2017:15:00:00 +0200


opsi-client-agent (4.0.7.16-3) stable; urgency=low

* quickfixwin2012 #2966

-- Bardo Wolf <b.wolf@uib.de> Tue, 11 Jul 2017:15:00:00 +0200

opsi-client-agent (4.0.7.16-2) stable; urgency=low

* patcha fix: opsi 3.x implementation removed

-- Erol Ueluekmen <e.ueluekmen@uib.de> Tue, 11 Jul 2017:14:00:00 +0200

opsi-client-agent (4.0.7.16-1) stable; urgency=low

* upgrade to opsi-script 4.11.6.13
* new notifier (lazarus version) 4.0.7.0
* ssl library upgrade to 1.0.2.12 (1.0.2L) (do 16.6.2017)
* remove property on_uninstall
handled internal: at XP always deactivate; on >= Vista always uninstall
fixes: #438 (do 27.6.2017)

-- Detlef Oertel <d.oertel@uib.de> Mon, 29 May 2017:15:00:00 +0200

=======================================================

opsiclientkiosk 4.0.7.9

* minor fixes
* uses locale
* laz 1.6.4
* remove backend_exit after rebuild

-- detlef oertel <d.oertel@uib.de> Fri, 04 Aug 2017 15:00:00 +0000


opsiclientkiosk 4.0.7.8

* fix for font style
* productName instead of productId on top and bold
* webservice: use agent name and version
* webservice: call backend_exit after rebuild
* new checkbox 'expert mode' : less buttons if not checked
* detail panel now with klick-on / klick-off
* flat tile borders
* more left space on radiogroup
* resize radiogroup
* changed colors for Uninstall=red, Setup=green
* order by Upper(ProductName)
* new clear-searchedit-button 'in' searchedit field
* run only one instance
* mouse wheel works now also over tiles

-- detlef oertel <d.oertel@uib.de> Mon, 29 May 2017 15:00:00 +0000


opsiclientkiosk 4.0.7.7

* tile GUI
* uses now new opsi method: getKioskProductInfosForClient
* installdialog now systemStayOnTop
* filter button removed
* filter input with 500 ms wait for nest input before search
* display 'not installed' and 'none' as empty string
* faster store of action requests by handling only the note none/empty
* using now sqlite3 instead of TZMSQL (this requires sqlite3.dll)
* listview: sort on column header click
* remove group view and selection
* add customize option for product-tiles
* add translation for product-tiles
* fix in Upgradefilter

-- detlef oertel <d.oertel@uib.de> Fri, 03 Mar 2017 15:00:00 +0000


opsiclientkiosk 4.0.7.6

* fix (thread) for progressbar on button 'store actions' ; fixes #2586
* flowpanel on pagetile of NotebookProducts
* integrate dbtiletest to opsiclientkiosk

-- detlef oertel <d.oertel@uib.de> Wed, 22 Feb 2017 15:00:00 +0000

=====================================================

opsiclientd (4.0.92) stable; urgency=medium

* new version based on python-opsi 4.0.7.48-1

-- Erol Ueluekmen <e.ueluekmen@uib.de> Mon, 21 Aug 2017 16:10:32 +0200

opsiclientd (4.0.91) stable; urgency=medium

* based on python-opsi 4.0.7.45-1
* support for new kioskclient
* increasing default max cachesize for WAN-Module
* default wql changed to avoid problems with wlan configurations
* new build for win8 and win2012 support

-- Erol Ueluekmen <e.ueluekmen@uib.de> Mon, 07 Aug 2017 23:11:49 +0200

====

python-opsi changelogs:

python-opsi (4.0.7.48-1) stable; urgency=medium

* System.Windows.getActiveSessionIds fix for nt6
* hostControl: Implementation for modified opsiclientd controlserver
port over configState

-- Erol Ueluekmen <e.ueluekmen@uib.de> Mon, 21 Aug 2017 16:07:09 +0200

=======================================================
opsi-winst/opsi-script (4.12.0.4-1) stable; urgency=low

* postinst: configs "opsi-script.global.default_loglevel" and "opsi-script.global.force_min_loglevel" not editable
* osconf: readConfigFromService: protect from wrong data types from service

-- Detlef Oertel <d.oertel@uib.de> Fri, 01 Sep 2017:15:00:00 +0200

opsi-winst/opsi-script (4.12.0.3-1) stable; urgency=low

* global: rising the level of a lot of loging

-- Detlef Oertel <d.oertel@uib.de> Fri, 01 Sep 2017:15:00:00 +0200

opsi-winst/opsi-script (4.12.0.2) stable; urgency=low

* osbatchgui: ForceStayOnTop modified
* osbatchgui: ForceStayOnTop in form.activate
* osconf: default_loglevel = 6;
* osfunc: alldelete: del command: allow also partly wildcards (*.yxz or xyz.*)

-- Detlef Oertel <d.oertel@uib.de> Thu, 24 Aug 2017:15:00:00 +0200

opsi-winst/opsi-script (4.12.0.1) experimental; urgency=low

* oswebservice: changed loglevels in retrieveJSONObject
* osfunc: FindLocalIPData / getMyHostEnt : better Error handling

-- Detlef Oertel <d.oertel@uib.de> Thu, 27 Jun 2017:15:00:00 +0200

opsi-winst/opsi-script (4.12.0.0) experimental; urgency=low

* new unit osdefinedfunctions
* osparser: support for defined functions
* osparser: moved sync between FExtremeErrorLevel and extremeErrorLevel before final output
* osparser: new functions: boolToString(<bool expression>) and stringToBool(< string>)
* osparser: new statement: ImportLib
* oslog: new method log_prog for program debugging
* osconf: readConfigFromService reads configstates:
opsi-script.global.debug_prog : boolean ; if true log log_prog if > LLWarning
opsi-script.global.debug_lib : boolean ; if true log libraries if > LLWarning
opsi-script.global.default_loglevel : intstring ; set the default loglevel
opsi-script.global.force_min_loglevel : intstring ; set the minimal loglevel
* osmain: if /productid is set then use it also for the log
* opsihwbiosInfo: typo Manufacturer ; fixes #2994

-- Detlef Oertel <d.oertel@uib.de> Mon, 19 Jun 2017:15:00:00 +0200


opsi-winst/opsi-script (4.11.6.15) stable; urgency=low

* osfunc: alldelete: del command: allow also partly wildcards (*.yxz or xyz.*)
(backport from 4.12.0.2)

-- Detlef Oertel <d.oertel@uib.de> Fri, 25 Aug 2017:15:00:00 +0200

opsi-winst/opsi-script (4.11.6.14) stable; urgency=low

* osparser: isNumber: now check against int64
* osparser: new file section copy option -h (follow symlinks; default=false)
* osfunc: support for followsymlinks:
FileInstall.AllCopy: AllCopy Recursive: ToCopyOrNotCopy
filecopy : fixes #2537
Files section copy: -s : does not follow symlinks but copy the symlink files
copy -h : follow symlinks

-- Detlef Oertel <d.oertel@uib.de> Thu, 29 Jun 2017:15:00:00 +0200

opsi-winst/opsi-script (4.11.6.13) stable; urgency=low

* oswebservice: typo: lastcation
* osbatchgui: use myStringToTColor to interpret rgb colors from ini file

-- Detlef Oertel <d.oertel@uib.de> Mon, 29 May 2017:15:00:00 +0200

=================================================

swaudit (4.0.7.6-2) stable; urgency=low

* use of property 'max loglevel' modified

-- detlef oertel <d.oertel@uib.de> Wed, 06 Sep 2017 15:00:00 +0100

swaudit (4.0.7.6-1) stable; urgency=low

* fix version in Linux swaudit

-- detlef oertel <d.oertel@uib.de> Wed, 06 Sep 2017 15:00:00 +0100


swaudit (4.0.7.5-1) stable; urgency=low

* integrate Linux swaudit
* append win10 ReleaseId to displayversion of windows
* onyly one Logline per product
* Use in service mode %opsiserviceUser% as $clientId$
* windows 10 version is now 10 (not 6.3 (from registry))

-- detlef oertel <d.oertel@uib.de> Fri, 01 Sep 2017 15:00:00 +0100

=================================================

opsi-linux-client-agent (4.0.7.13-1) stable; urgency=medium

* opsi-script 4.12.0.4

-- d.oertel <d.oertel@uib.de> Wed, 06 Sep 2017 15:00:00 + 0100


opsi-linux-client-agent (4.0.7.12-1) UNRELEASED; urgency=low

* added opsiclientd for OpenSUSE Leap 42.3.
* corrected opsiclientd checks for openSUSE 42.2 and 42.3
* New opsiclientd builds.
* opsi-script 4.11.6.14
* SLES12 installs opsiclientd fine

-- Mathias Radtke <m.radtke@uib.de> Thu, 27 Jul 2017 08:54:00 +0200

opsi-linux-client-agent (4.0.7.11-1) experimental; urgency=medium

* opsi-script 4.12.0.0

-- d.oertel <d.oertel@uib.de> Wed, 26 Jul 2017 15:00:00 + 0100


opsi-linux-client-agent (4.0.7.10-1) testing; urgency=medium

* Added opsiclientd for opensuse 42.2.

-- Niko Wenselowski <n.wenselowski@uib.de> Fri, 21 Jul 2017 14:49:13 + 0100


opsi-linux-client-agent (4.0.7.9-1) stable; urgency=medium

* fixes: #2977

-- d.oertel <d.oertel@uib.de> Tue, 11 Jul 2017 15:00:00 + 0100

opsi-linux-client-agent (4.0.7.8-1) stable; urgency=medium

* upgrade to opsi-script 4.11.6.14:
Files section copy: -s : does not follow symlinks but copy the symlink files
copy -h : follow symlinks

-- d.oertel <d.oertel@uib.de> Tue, 30 Jun 2017 15:00:00 + 0100

opsi-linux-client-agent (4.0.7.7-3) stable; urgency=medium

* The internal var $upgrade_before_install$ is set to 'true'
if the parameter bootimage is set (this is the case while the installation from netboot product)

-- d.oertel <d.oertel@uib.de> Tue, 26 Jun 2017 15:00:00 + 0100

=================================================
opsi support - uib gmbh

For productive opsi installations we recommend support contracts.
http://www.uib.de
http://www.opsi.org

Zurück zu „News“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast